ProjectsWhat's NewDownloadsCommunitySupportCompany
Forum Index » S.T.A.L.K.E.R.: Clear Sky Forum » Bugs & Tech support
old DX10 mouse problem....help!

Posted by/on
Question/AnswerMake Newest Up Sort by Descending
  02:39:17  12 January 2015
profilee-mailreply Message URLTo the Top
Emmet Otter
Senior Resident
 

 
On forum: 03/11/2008
 

Message edited by:
Emmet Otter
01/12/2015 2:43:12
Messages: 230
old DX10 mouse problem....help!

I just got myself a new rig GTX970 4.0 Intel, the works.....

Im able to max out all my games with no problems so far, except for CS DX10 mode. Its the mouse confined to a small resolution at higher resolution settings problem. My desktop is 2560x1600 and I prefer to play CS @ 1680x1050 but my mouse restrictions are like 1024x768. Ive read to try alt/tab'n out and go back in, but that didnt work. Playing windowed mode helps the problem but I cant stand windowed games. I also tried to set my desktop at the same resolution but that also did not help. I am at a loss here. I went back like 6 years of pages here with not much to find.

I wanna play FW3.8 at CS's full glory but cant. Im at ver 1.5.10 on windows 7.

Any help on this wold be greatly appreciated.
  15:20:51  12 January 2015
profilee-mailreply Message URLTo the Top
Three Mile Island
Senior Resident
 

 
On forum: 11/04/2008
 

Message edited by:
Three Mile Island
01/12/2015 15:24:53
Messages: 2378
I had a similar problem when I upgraded my video card from Nvidia GTX 8800 to 660: https://www.gsc-game.com/index.php?t=community&s=forums&s_game_type=xr2&sec_id=19 but later it went away by itself. Maybe it had something to do with upgrading drivers, restarting Windows or restarting Stalker (or start a new game?).
  03:26:51  13 January 2015
profilee-mailreply Message URLTo the Top
Emmet Otter
Senior Resident
 

 
On forum: 03/11/2008
Messages: 230
I just installed FW3.8 just fresh yesterday and started a new game. The problem still persist.

That link you've provided just bring me back to the main 'bugs' page. Thanks for replying though.
  11:17:07  13 January 2015
profilee-mailreply Message URLTo the Top
romulous
Senior Resident
 

 
On forum: 12/28/2007
Messages: 1868
It's a very odd sounding problem. There are third party utilities that can restrict mouse boundaries, but I assume you would know if you are running one of those. Have you changed your Windows DPI settings (if so, does changing it back to 100% fix it)? Have you tried deleting your user.ltx file (CS will re-create this when you start the game again, but you will need to set the various game settings again).
  14:55:04  13 January 2015
profilee-mailreply Message URLTo the Top
Three Mile Island
Senior Resident
 

 
On forum: 11/04/2008
Messages: 2378

---QUOTATION---
That link you've provided just bring me back to the main 'bugs' page.
---END QUOTATION---


It didn't say anything terribly useful:


---QUOTATION---

with DX10 enabled I got the following strange effects:

- My Windows desktop background became smaller.

- Sometimes the game (including splash screens) launched in "widescreen" proportions, despite me using non-widescreen resolutions.

- I couldn't move the mouse across the whole screen, making it tricky to change some of the settings. The extent of this appeared to be a bit random.

---END QUOTATION---



Now I rechecked my current (working) CS settings. Seems I use the same 1600x1200 resolution in CS as in Windows (this is with a CRT monitor).

I also use DX10, and when I now quick-tested DX10.1 it seems to work fine as well. CS really blows CoP out of the water graphic-wise.

My Windows DPI setting is at 100%. I recall experimenting with higher values long time ago, can't remember what made me go back to 100% but I don't think it was game-related.
  21:14:53  13 January 2015
profilee-mailreply Message URLTo the Top
RK Roadkill
Merc
(Resident)

 

 
On forum: 05/27/2011
Messages: 1296
I got no problem running CS maxed out on my AMD 7850 Saphirre.

Runs smooth....
  12:52:09  14 January 2015
profilee-mailreply Message URLTo the Top
romulous
Senior Resident
 

 
On forum: 12/28/2007
Messages: 1868

---QUOTATION---
My Windows DPI setting is at 100%. I recall experimenting with higher values long time ago, can't remember what made me go back to 100% but I don't think it was game-related.
---END QUOTATION---



The reason why I asked that question was that I did find a report of a similar sounding issue, and the OP fixed it by reverting his DPI settings back to 100%
  01:16:56  15 January 2015
profilee-mailreply Message URLTo the Top
Emmet Otter
Senior Resident
 

 
On forum: 03/11/2008
 

Message edited by:
Emmet Otter
01/15/2015 1:19:36
Messages: 230
GUYZ!! Romulous, Three Mile Island, thanks for your help! The DPI settings did the trick. I had mine set at 150% and dropping it back down to 100% worked. Its wierd cause I did a google search and checked back several years here with no one mentioning of DPI settings and many people had experienced this problem. Man, you guys know your shit!!

Thanks for taking the time to help me out.
  02:35:29  15 January 2015
profilee-mailreply Message URLTo the Top
Three Mile Island
Senior Resident
 

 
On forum: 11/04/2008
 

Message edited by:
Three Mile Island
01/15/2015 3:18:18
Messages: 2378

---QUOTATION---
Man, you guys know your shit!!
---END QUOTATION---


At least romulous does...

Now I did some tests (Vista 32bit, Nvidia GeForce 660 GTX, Clear Sky 1.5.10 using DX10.1):

- Even with the same resolution in CS and Windows, increasing Windows DPI to 120% restricts mouse movement in Clear Sky. But when I right-click on the Clear Sky shortcut, choose Properties > Compatibility and tick "deactivate scaling at high DPI" the mouse works properly again.

- Higher resolution in CS than in Windows also restricts mouse movement in Clear Sky, even with 100% DPI, and "deactivate scaling at high DPI" doesn't seem to help.
  11:20:38  15 January 2015
profilee-mailreply Message URLTo the Top
romulous
Senior Resident
 

 
On forum: 12/28/2007
Messages: 1868
It's always nice to see a problem solved Credit goes to Jeffro, here:
http://forums.steampowered.com/forums/showthread.php?t=2719909

Thankfully, Jeffro seems to be someone who believes in updating a thread when you self-solve a problem! I have lost count of the number of times I have seen a thread describing a problem, and there is either no follow-up, or there is just a single follow-up post along the lines of 'nevermind, fixed it' with no mention of what the fix was.
 
Each word should be at least 3 characters long.
Search:    
Search conditions:    - spaces as AND    - spaces as OR   
 
Forum Index » S.T.A.L.K.E.R.: Clear Sky Forum » Bugs & Tech support
 

All short dates are in Month-Day-Year format.


 

Copyright © 1995-2019 GSC Game World. All rights reserved.
This site is best viewed in Internet Explorer 4.xx and up and Javascript enabled. Webmaster.
Opera Software products are not supported.
If any problem concerning the site functioning under Opera Software appears apply
to Opera Software technical support service.