ProjectsWhat's NewDownloadsCommunitySupportCompany
Forum Index » S.T.A.L.K.E.R.: Shadow of Chernobyl Forum » Mod discussion
Script / Mod Repository?

Posted by/on
Question/AnswerMake Newest Up Sort by Descending
  01:52:19  9 February 2013
profilee-mailreply Message URLTo the Top
McMick
(Senior)
 
On forum: 08/05/2008
 

Message edited by:
McMick
02/09/2013 1:57:18
Messages: 108
Script / Mod Repository?

I've noticed that people trying to mod STALKER come here and ask questions to problems that were solved years ago in someone else's mod. Has anyone tried to create a script/mod repository to make it easy to find code that does what a modder wants? Does one exist that I'm ignorant of?

I've seen several mods over the years that were essentially compilations of other mods, so I understand that of course modders eventually figure it out on their own, but it seems to me that if the useful functions found in a mod were separated and made available for individual download, it would serve the modding community better.

Example: Let's say I'm creating a mod and I want to be able to heal wounded enemy units and make them neutral or friendly (I thought of this idea on my own before finding out it had already been made). A few mods have this option, but I've never seen it posted as a stand-alone mod or script that anyone can use. I could spend a bunch of time figuring out how to do it, or come on this forum and ask, but if I could just see the code already made in a nice, neat package, it should be easy to implement into my mod. Does that sound logical?

I've only ever dipped my toe into modding waters, so I can't say whether my idea is any good or not. Sorry if I'm wasting space :\
 
Each word should be at least 3 characters long.
Search:    
Search conditions:    - spaces as AND    - spaces as OR   
 
Forum Index » S.T.A.L.K.E.R.: Shadow of Chernobyl Forum » Mod discussion
 

All short dates are in Month-Day-Year format.


 

Copyright © 1995-2021 GSC Game World. All rights reserved.
This site is best viewed in Internet Explorer 4.xx and up and Javascript enabled. Webmaster.
Opera Software products are not supported.
If any problem concerning the site functioning under Opera Software appears apply
to Opera Software technical support service.