ProjectsWhat's NewDownloadsCommunitySupportCompany
Forum Index » S.T.A.L.K.E.R.: Shadow of Chernobyl Forum » Mod discussion
Adapting 1.0004 to 1.0005

« Previous 10 events | 1 2 | All Messages
Posted by/on
Question/AnswerMake Newest Up Sort by Descending
  04:04:42  5 March 2013
profilee-mailreply Message URLTo the Top
Jketiynu
Swartz
(Resident)

 

 
On forum: 04/05/2007
Messages: 867
It's reasons like this that I'm glad I have disc copies of the three Stalker games. Steam can be a pain in the ass when it comes to games that you may not want to use the latest patch for.
  05:45:49  5 March 2013
profilee-mailreply Message URLTo the Top
NatVac
Senior Resident
 

 
On forum: 06/15/2007
Messages: 4282

---QUOTATION---
Is there some sort of universal method to adapt 1.0004 to the 1.0005 patch? I know some stuff was changed in the patches, but I'm unsure as to what it is. Any thing to look out for in terms of pitfalls and what have you would be great.
---END QUOTATION---


ddraig, xRatx pointed you at the changed files.

They changed the numeric IDs for the dialog text to strings in 1.0005.

Details are in the Compatibility sticky topic.

¯¯¯¯¯¯¯¯¯¯
>> i never used to edit registry, it's unnecessary

That's because you did the smart thing of unpacking the patch executable, Bangalore. I'm not a fan of installers, but they make it easy for the folks who prefer simplicity over control. Then they have UAC and shadow copy/virtual store issues, and that makes it hard for everyone.

I do what FatalFunnel does, keeping separate binary install folders.

¯¯¯¯¯¯¯¯¯¯
>> Patches should be by choice. I always bought retail Stalker games anyway.

I agree, Audioave10. I've played with all of the patches, and they seem to have different uses. Wide-screen players might benefit from 1.0006, but there's lots of unecessary log spew, a new crash when eating off a dead body (heh) and a known multiplayer security vulnerability (ironic when you consider it is the version of choice for MP). 1.0005 makes better use of graphics capabilities, but it taxes my older video card more than earlier versions.

So my personal preference is for 1.0004 from among the last three patches. This is without regard to mods; I can always patch a mod to work with any version, aside from the binaries. (Shameless plug: notice how ZRP works OOTB with all three of these patches?)

I actually prefer 1.0001 with some script fixes. No delayed spawning, no hitches. I'll return to it some day soon.
 
Each word should be at least 3 characters long.
Search:    
Search conditions:    - spaces as AND    - spaces as OR   
 
Forum Index » S.T.A.L.K.E.R.: Shadow of Chernobyl Forum » Mod discussion
 

All short dates are in Month-Day-Year format.


 

Copyright © 1995-2020 GSC Game World. All rights reserved.
This site is best viewed in Internet Explorer 4.xx and up and Javascript enabled. Webmaster.
Opera Software products are not supported.
If any problem concerning the site functioning under Opera Software appears apply
to Opera Software technical support service.