ProjectsWhat's NewDownloadsCommunitySupportCompany
Forum Index » S.T.A.L.K.E.R.: Shadow of Chernobyl Forum » Mod discussion
Lost World Troops of Doom

« Previous 10 events | 1 ... 31 32 33 34 35 36 37 38 39 40 | Next 10 events »
Posted by/on
Question/AnswerMake Newest Up Sort by Descending
  00:51:12  28 May 2012
profilee-mailreply Message URLTo the Top
DooMike
The Janitor
(Resident)

 

 
On forum: 01/31/2009
Messages: 415
Hello-hello?!

Having finished Secret Trails 2 recently, i´ve been scouting this mod and the progress with translating it.

Seeing this has resulted in a recent release, i have a request:

Could somebody please update a "what to download and how to install this mod at present date" in the mod downloads section... it´s a bit of a shamble in there...

Can´t offer much other than gratitude, but i´m sure i wont the only one mentioning "whom it may concern" in my prayers!
  08:29:56  28 May 2012
profilee-mailreply Message URLTo the Top
gunso
Senior Resident
 

 
On forum: 01/24/2011
 

Message edited by:
gunso
05/28/2012 11:15:15
Messages: 230
@ZaGaR


---QUOTATION---
There it is.

http://rghost.net/38321300

I called it Translations_Beta_0.1
Good luck and good hunting stalkers.
---END QUOTATION---


=========================================

Thanks for the early release but I've run into a snag while loading for the first time, and here's the result:

FATAL ERROR

[error]Expression : fatal error
[error]Function : CStringTable::Load
[error]File : E:\stalker\sources\trunk\xr_3da\xrGame\string_table.cpp
[error]Line : 53
[error]Description : <no expression>
[error]Arguments : string table xml file not found aem_strings.xml, for language eng


stack trace:
-----------------------------------------------------------------------------
Looks to me as there's a missing-in-action file.

> > > EDIT < < <
found a couple more and I took them from the 'rus' folder to continue, but, i LUA script stopped me dead in my tracks. Here they are for your inspection:

==============================================================================================
FATAL ERROR

[error]Expression : fatal error
[error]Function : CStringTable::Load
[error]File : E:\stalker\sources\trunk\xr_3da\xrGame\string_table.cpp
[error]Line : 53
[error]Description : <no expression>
[error]Arguments : string table xml file not found stable_dialogs_garbage_rzt.xml, for language eng


stack trace:
===========================================================================================================
FATAL ERROR

[error]Expression : fatal error
[error]Function : CStringTable::Load
[error]File : E:\stalker\sources\trunk\xr_3da\xrGame\string_table.cpp
[error]Line : 53
[error]Description : <no expression>
[error]Arguments : string table xml file not found stable_storyline_info_new.xml, for language eng


stack trace:
=============================================================================================================
=============================================================================================================
FATAL ERROR

[error]Expression : fatal error
[error]Function : CScriptEngine::lua_error
[error]File : E:\stalker\sources\trunk\xr_3da\xrGame\script_engine.cpp
[error]Line : 73
[error]Description : <no expression>
[error]Arguments : LUA error: ...s 4fun\stalker_v06 lwtod\gamedata\scripts\_g.script:313: attempt to index field 'tBoxFix' (a nil value)


stack trace:
------------------------------------------------------------------------------------------
Waitin' to see what comes next...
  09:50:28  28 May 2012
profilee-mailreply Message URLTo the Top
motanut
Senior Resident
 

 
On forum: 03/09/2010
 

Message edited by:
motanut
05/28/2012 9:57:45
Messages: 327
what version we should use for the beta translation to work ?

and thanks for sharing with us your the hard work

edit ...

is good in this way ?


---QUOTATION---
The installation order is below. Point 6 is needed only if one plays with DX9-renderer_r2.
1- Bring ShoC to 1.0006 patch level.
2- Delete all existing \gamedata, of any LW series you may have in ShoC's folder.
3- Unpack the mod's files from the module lwtod3.0_fixed.exe, at a location you choose.
4- There is a \bin folder in the archive to go on top of the game's default \bin (save first)
5- Move the unpacked \gamedata inside your 1.0006 installation.
6- Extract/install the files from Dynamic Patch overwriting the above \gamedata.
7- Extract the files from patch3.3_lwtod.7z overwriting again the \gamedata.
8- Start playing .
When the translations become available, will again overwrite the existing files.
---END QUOTATION---

  11:12:04  28 May 2012
profilee-mailreply Message URLTo the Top
X-RaY2
(Senior)
 
On forum: 05/15/2012
Messages: 94
Do i really need 1.0006 patch does it work for 1.0004?
  11:45:19  28 May 2012
profilee-mailreply Message URLTo the Top
ZaGaR
Skaarj Hybrid - NaPali survivor
(Resident)

 

 
On forum: 07/24/2007
Messages: 647
Ok guys! Let me explain as much as I can.

1- The translations are from 3.3. The text files are definitely compatible with 3.5 Kocayine, but the scripts are definitely NOT, so use selectively. I converted some of thes cripts to 3.5 level (the LWC_xxx bunch), but there is more to it like the config\gameplay folder, config\misc folder and the config\weapons. If you use only config\text and config\ui you will have a good % of english except the upgrading menus and vehicle menus.


2- The setup order DooMike is precisely the one motanut is quoting. You will find it a few pages back. Everything in the translations package overwrites the setup. I the installation order it goes after step 7 and before the step 8 . But, check the end of this post for an extra step.

3- gunso, you're came up with the first bug report . I believe I completely forgot to do the Arena Extensions Manager translations. I skipped it initially for the more relevant files, then forgot it. So this brings us to an additional setup step for everyone concerned:

!! Extra steps:
7.5 - Rename the config\text\rus folder to \eng at the end of the step 7, meaning AFTER applying to the game to the 3.3 patch files.
7.6 - Overwrite the installed \gamedata with the gamedata folder from the translations.
8. -

Alternatively, in cases like gunso's, where everything is already set, you can take the file aem_strings.xml from the \rus folder to the \eng folder. Repeat the process if other files pop up as missing.
  12:22:30  28 May 2012
profilee-mailreply Message URLTo the Top
gunso
Senior Resident
 

 
On forum: 01/24/2011
Messages: 230
Thanks ZaGaR, so I'll wait to see what you do about the LUA error...
  12:28:41  28 May 2012
profilee-mailreply Message URLTo the Top
Kocayine
Senior Resident
 

 
On forum: 07/15/2010
Messages: 918
ZaGar

It's ok, I went ahead and merged the translation with the 3.5 patch. Should be okay.
  13:21:32  28 May 2012
profilee-mailreply Message URLTo the Top
nashathedog
Senior Resident
 

 
On forum: 01/31/2011
Messages: 8423
I am unsure what parts to put with what so I have downloaded this from Zagar and am in Predbannik. Theres a fella who gives info on artefact abilities but I asked for the info on the night star for cheapskate and got this.


FATAL ERROR

[error]Expression : no_assert
[error]Function : CXML_IdToIndex<class CInfoPortion>::GetById
[error]File : e:\stalker\sources\trunk\xr_3da\xrgame\xml_str_id_loader.h
[error]Line : 112
[error]Description : item not found, id
[error]Arguments : info_af_night_star
  13:27:59  28 May 2012
profilee-mailreply Message URLTo the Top
motanut
Senior Resident
 

 
On forum: 03/09/2010
 

Message edited by:
motanut
05/28/2012 13:29:25
Messages: 327
please, you can share them with us ?


---QUOTATION---
I went ahead and merged the translation with the 3.5 patch. Should be okay.
---END QUOTATION---

  17:27:25  28 May 2012
profilee-mailreply Message URLTo the Top
ZaGaR
Skaarj Hybrid - NaPali survivor
(Resident)

 

 
On forum: 07/24/2007
 

Message edited by:
ZaGaR
05/28/2012 17:59:34
Messages: 647
@davideverett

Do not use my download. You have received bit-by-bit all the files needed, and what you have is probably more, and more accurate that what I have Please assemble those in the same format as the one I posted, using it only as a guide for the file list. Particularly, the config\scripts folder you've got has the proper 3.3 scripts, mine has a mix with 3.5. We were all waiting from iLoveShoC and you to correct the english and publish the translations, not the other way around.

@gunso

I will see what is the "tBoxFix..." problem, but the safest way is to implement the originally translated scripts from 3.3. They should be with davideveret and ILS. I think davideverett can upload only the \gamedata\scripts folder without a problem.


@kocayine

Please start a game to see if my 3.3-to-3.5 transition is working in your case. I wanted to continue a 3.3 game with the 3.5 fixes, without starting from 0. You will have the all.spawn of 3.5 with config files that can be partially of 3.3.

EDIT:

I checked the uploaded archive to find out that it doesn't contain lwc_function.script, since it is not related to translations. Anyway, it seems to be needed because of the version tweaks. gunso, if you have downloaded the 3.5 patch, take this script from it and overwrite the one in game's folder. Let's see how it goes.

EDIT:
davideverett, check the lwc_artefact.script. There is a long list at the beginning which should have a lot of info_af_xxx entries. See if there is a damage or missing quote. Night Star has the proper entries in the text files.
 
Each word should be at least 3 characters long.
Search:    
Search conditions:    - spaces as AND    - spaces as OR   
 
Forum Index » S.T.A.L.K.E.R.: Shadow of Chernobyl Forum » Mod discussion
 

All short dates are in Month-Day-Year format.


 

Copyright © 1995-2022 GSC Game World. All rights reserved.
This site is best viewed in Internet Explorer 4.xx and up and Javascript enabled. Webmaster.
Opera Software products are not supported.
If any problem concerning the site functioning under Opera Software appears apply
to Opera Software technical support service.