ProjectsWhat's NewDownloadsCommunitySupportCompany
Forum Index » S.T.A.L.K.E.R.: Shadow of Chernobyl Forum » Mod discussion
Errors with some merged files and particle.xr

Posted by/on
Question/AnswerMake Newest Up Sort by Descending
  22:48:25  13 November 2014
profilee-mailreply Message URLTo the Top
Das_P0m
(Novice)
 
On forum: 01/26/2011
 

Message edited by:
Das_P0m
11/13/2014 23:34:51
Messages: 45
Errors with some merged files and gamemtl.xr

Hi,

first of all... I'm not good at programming and scripts.
But I've learned a bit, tried to read and understand them.
So I merged some mods with the latest ZRP 1.07 R5EE.
For this a tried to merge some things out of bamahs addons for ZRP.

Dynamic campfires and bushes with masses (slow you down, if you run through them) and like the change-log said, I used also the modified gamemtl.xr.

I was freaking out as I saw, that it works^^
But then I entered yantar and some zombie hit the water with a bullet...

Error... oh no...><

The log tells me this:

FATAL ERROR

[error]Expression : SG
[error]Function : CRender::model_CreateParticles
[error]File : E:\stalker\sources\trunk\xr_3da\xrRender_R2\r2.cpp
[error]Line : 330
[error]Description : Particle effect or group doesn't exist
[error]Arguments : hit_fx\hit_water_bulet


stack trace:

Then I delete the gamemtl.xr for testing -> it works.

So the problem is spotted... nearly.
I also use the particle.xr form the addons and the folder "amik".

Here is what the change log provides:


Bushes Have mass
adds friction for ACTOR going thru bushes from AVS 1.5
[particle.xr]-added hit_fx\hit_concrete_00 Particle effect, added amik effects
gamemtl.xr
sounds\material
textures\amik



The only thing I could find out about "hit_water_bulet" was, that it is related to the "amik" folder and it was added by some Russian modders to a also modified particle.xr, but no single hint about this error.
Also on my harddisk with several GB of mods from stalker, there was no file, or folder or whatsoever...

So I guess... its related to the fact, that I've missed something.

I've managed to decompile the gamemtl.xr with a tool that smrter provided here in the forum.
More than 1800 files were extracted...><
Maybe I will find the ltx file with the path and maybe I manage to solve this problem...

... but it would be nice if anybody can help me out with this problem.
I learned so much about modding stalkers since years, but as I can see... not enough

I would really like to keep this feature in the mod, would be a shame to kick them out again after this hard work (for me ) to implement them.


Greetz

Glasauge aka Das_P0m


EDIT:

I was able to decompile the gamemtl.xr, searched for the string, found it, decompile the original gamemtl.xr and compared the files.
Now I've copied over the "old" entries and compile it to a new one.
No I can shoot again into water without crash, but there is no particle effect for it.
The bullet just disappears the water remains untouched.

Well... if this works... fine.

If anyone else has a good work around, or better... a solution, its still welcome!
 
Each word should be at least 3 characters long.
Search:    
Search conditions:    - spaces as AND    - spaces as OR   
 
Forum Index » S.T.A.L.K.E.R.: Shadow of Chernobyl Forum » Mod discussion
 

All short dates are in Month-Day-Year format.


 

Copyright © 1995-2022 GSC Game World. All rights reserved.
This site is best viewed in Internet Explorer 4.xx and up and Javascript enabled. Webmaster.
Opera Software products are not supported.
If any problem concerning the site functioning under Opera Software appears apply
to Opera Software technical support service.