ProjectsWhat's NewDownloadsCommunitySupportCompany
Forum Index » S.T.A.L.K.E.R.: Shadow of Chernobyl Forum » Mod discussion
Odd CTD

« Previous 10 events | 1 2 3 4 | All Messages
Posted by/on
Question/AnswerMake Oldest Up Sort by Ascending
  15:08:14  6 September 2010
profilee-mailreply Message URLTo the Top
notanumber
mod abuser & exploiter
(Resident)

 

 
On forum: 03/22/2008
Messages: 2822

---QUOTATION---
Odd CTD
stack trace:

0023:0040D025 XR_3DA.exe, CEnvAmbient::get_rnd_sound_time()
0023:7566206C iertutil.dll
0023:03D21D30 xrGame.dll


---END QUOTATION---


Dunno but I'd suspect something in env_ambient.ltx being outside of the range that the game can handle...
Is the problem reproducible?
  09:54:05  6 September 2010
profilee-mailreply Message URLTo the Top
Vintar
a bit of this and a lot of that
(Resident)

 

 
On forum: 08/08/2008
Messages: 6349
Is it possible to revert back to vanilla ambient sounds and retest?
  03:08:57  6 September 2010
profilee-mailreply Message URLTo the Top
{imperialreign}
Звуковой Шаман
(Resident)

 

 
On forum: 10/29/2008
Messages: 3075
Odd CTD

Yerp, got another one I can't seem to circumvent, and can't pinpoint what's cuasing it, either.


stack trace:

0023:0040D025 XR_3DA.exe, CEnvAmbient::get_rnd_sound_time()
0023:7566206C iertutil.dll
0023:03D21D30 xrGame.dll



As of now, it only occurs in Stancia 1 and Sarcophagus . . . I can't get anymore than 5 minutes into the sarco before hitting this wall - I'm starting to believe this is some sort of timed-out error . . .

Running a minimal setup - SWO3+AAOv1.8

My first thought was that it was related to AAO . . . even though I never encountered this error during playtesting (nor playtesting compatibility with SWO3 or DW) . . . but, double checking all AAO configs and everything is fine. As well, if there was an issue within any of the weather sections, it would casue a CTD upon initial game startup - not at some random point in time after loading a saved game.

I had then thought it was related to the monolith call within the sarcophagus, and had attempted to adjust the timer there, and double check the sound_theme.script - all's well. It wasn't until I started fiddling around in Stancia1 that I noticed this problem there as well, so it couldn't be related to a config script and ph executions.

My only other thought was that it was possibly something corrupt within the saved game itself - so I went back to an earlier save (furthest being 10 in-game days prior to noticing this CTD) . . . then made a rush through AW, RF, Pri . . . only to discover the error is still there, leading me to believe it's probably not an issue with the save. I haven't yet tried a new game and speed through to these areas (which is next on my agenda) . . .

Any thoughts, guys? Only other conclusion I have would be excessive use/abuse of the weather speed-up function (provided via SWO3/DW). This isn't anything critical or requiring immediate attention, as I'm mearly doing some playtesting and taking sound samples. I'm just wanting to make 100% sure it's not an AAO issue - and if it is, get to the root of it so I can get a patch out.
 
Each word should be at least 3 characters long.
Search:    
Search conditions:    - spaces as AND    - spaces as OR   
 
Forum Index » S.T.A.L.K.E.R.: Shadow of Chernobyl Forum » Mod discussion
 

All short dates are in Month-Day-Year format.


 

Copyright © 1995-2021 GSC Game World. All rights reserved.
This site is best viewed in Internet Explorer 4.xx and up and Javascript enabled. Webmaster.
Opera Software products are not supported.
If any problem concerning the site functioning under Opera Software appears apply
to Opera Software technical support service.