ProjectsWhat's NewDownloadsCommunitySupportCompany
Forum Index » S.T.A.L.K.E.R.: Shadow of Chernobyl Forum » Mod discussion
Odd CTD

« Previous 10 events | 1 2 3 4 | Next 10 events »| All Messages
Posted by/on
Question/AnswerMake Newest Up Sort by Descending
  14:35:55  8 September 2010
profilee-mailreply Message URLTo the Top
{imperialreign}
Звуковой Шаман
(Resident)

 

 
On forum: 10/29/2008
Messages: 3075
I'll check that stuff out later this evening. I've noticed (at least in stancia1) that it appears to happen more frequently with the rain configs.

I'll also throw the debug back on, see if that might toss something into the log that can fit a pattern to the whole puzzle. As well, I'll do some further experimenting with the weather/ambient configs. It's a little confusing, though, how AAO:vanilla doesn't seem to be a problem - and it uses the same ambient loadouts that SWO3/DW use . . . partly why I'm currently assuming it's an issue introduced via script . . .

I can't remember if the engine still loads outside weather when inside (I thought it only did with env_mod mapped areas), but I could see where that's causing problems . . . if the issue lies only in stancia1.

Anyhow - hopefully we can get to the bottom of this error . . . some googling has turned up other mods with this problem - and they all seem to be using some configuration of AAO with SWO3 or DW.

Damn stack trace errors - such a buggar to pin down.
  15:00:03  8 September 2010
profilee-mailreply Message URLTo the Top
Vintar
a bit of this and a lot of that
(Resident)

 

 
On forum: 08/08/2008
Messages: 6349
Dont have the files infront of me, but check if there is a script in SHOC called xr_zones_sound.script, seems like the sort of stuff youre having problems with.
  15:18:56  8 September 2010
profilee-mailreply Message URLTo the Top
notanumber
mod abuser & exploiter
(Resident)

 

 
On forum: 03/22/2008
 

Message edited by:
notanumber
09/08/2010 15:19:15
Messages: 2822
DW script doesn't load outside weather, it just determines the weather cycle that is curently selected. It does, however, issue the level.set_weather() call. I don't know if this can cause problems when ambient is modded and the weather cycle is set to what it already is. To prevent this you could try and change the following piece of code in level_weathers.script:
    if (not olp_mod or amk.load_variable("blowout", 0) == 0)
       and (not blowout or blowout.GetBlowout().is_blowout_on == false)
       and (not ogsm_funcs or ogsm_funcs.load_variable("blt", 0) == 0)
       and (not Psy or (db.Flag2 == 0 and db.Flag3 == 0 and db.Flag4 == 0 and db.Flag5 == 0))
    then
        level.set_weather(self.cur_weather)
    elseif olp_mod and amk_mod.blowout_type() < 1 then
        level.set_weather("pre_blow")
        level.set_weather_fx("amk_surge_day")
    end

to:
    if (not olp_mod or amk.load_variable("blowout", 0) == 0)
       and (not blowout or blowout.GetBlowout().is_blowout_on == false)
       and (not ogsm_funcs or ogsm_funcs.load_variable("blt", 0) == 0)
       and (not Psy or (db.Flag2 == 0 and db.Flag3 == 0 and db.Flag4 == 0 and db.Flag5 == 0))
       and level.get_weather() ~= self.cur_weather
    then
        level.set_weather(self.cur_weather)
    elseif olp_mod and amk_mod.blowout_type() < 1 then
        level.set_weather("pre_blow")
        level.set_weather_fx("amk_surge_day")
    end

  02:45:45  10 September 2010
profilee-mailreply Message URLTo the Top
{imperialreign}
Звуковой Шаман
(Resident)

 

 
On forum: 10/29/2008
Messages: 3075
Little more info -

I tried swapping numerous "known good" ambient sections around for the two problem maps (stancia and sarcophagus) - no change.

Tried the alteration to the DW script - no change.

I was able to get a slightly different error log kick:


stack trace:

0023:0040D025 XR_3DA.exe, CEnvAmbient::get_rnd_sound_time()
 
[error][      87]    : The parameter is incorrect.




when attempting to load a save game made in Pripyat. Still, though, it's not much helpful.

I haven't been able to consistently duplicate the problem in Pripyat . . . but, I've noticed that stancia is somewhat reproducible. When running along the train tracks towards the entrance to stancia - usually right around the last set of rail cars just before the entrance to the NPP - is when it will kick. Although, it seems, taking the "long way" around via the TZ doesn't seem to trigger it . . .

Sarcophagus is still easily reproducible - load a save game, and CTD within 10 in-game minutes.

What doesn't make sense to me - if it was being kicked by a bad zone (i.e. radiation, anomaly field, psy, etc. - which is how it seems to be acting at this point), why doesn't it happen with vanilla or only AAO? The problem only seems to crop up with SWO3/DW . . .

. . . IDK, it's got me beating my head against a very hard wall.
  08:28:54  10 September 2010
profilee-mailreply Message URLTo the Top
Vintar
a bit of this and a lot of that
(Resident)

 

 
On forum: 08/08/2008
Messages: 6349
OH NO!!
stack trace:

[error][      87]    : The parameter is incorrect.



This was the error I was getting in my "level change CTD"
Turns out this could be a number of things, at least yours point to ambient sound, mine said nothing :\
My error lay in a function in bind_stalker.

Good luck
  14:12:21  10 September 2010
profilee-mailreply Message URLTo the Top
{imperialreign}
Звуковой Шаман
(Resident)

 

 
On forum: 10/29/2008
 

Message edited by:
{imperialreign}
09/10/2010 14:17:25
Messages: 3075
You make it sound so thrilling, man!


Anyhow - my next route of testing is to reproduce the issue with only SWO3 and DW . . . no AAO, just vanilla ambients. That'll at least help me narrow down which portions of what mods are stirring the pot.

If it doesn't do it with either of those mod - then I'd bet pretty sure it's in the small area where the two mods are stitched together with AAO . . .


-EDIT-

Also, the only thing that really doesn't make much sense to me is why this would only happen on two (or three) specific levels . . . Haven't seen any issues with any of the other maps yet . . .
  16:26:07  10 September 2010
profilee-mailreply Message URLTo the Top
notanumber
mod abuser & exploiter
(Resident)

 

 
On forum: 03/22/2008
Messages: 2822
imp, if you could make a (small) download with the minimum "mod" needed to reproduce the CTD then I could try and reproduce it on my PC.
  01:49:23  11 September 2010
profilee-mailreply Message URLTo the Top
{imperialreign}
Звуковой Шаман
(Resident)

 

 
On forum: 10/29/2008
Messages: 3075

---QUOTATION---
imp, if you could make a (small) download with the minimum "mod" needed to reproduce the CTD then I could try and reproduce it on my PC.
---END QUOTATION---



I appreciate the offer, man

I'll do a strip-down and re-test, and try and post something up within the next day or two . . . in the mean time, I'll also continue prodding and testing things out as well.
  16:45:04  12 September 2010
profilee-mailreply Message URLTo the Top
{imperialreign}
Звуковой Шаман
(Resident)

 

 
On forum: 10/29/2008
 

Message edited by:
{imperialreign}
09/12/2010 16:45:44
Messages: 3075
Alright - I've pinned it down further . . .

It ONLY happens with SWO3 + full addons + AAO 1.8 installed.

DW 9.5 + AAO 1.8 (which equates to a gamedata of ~50MB) does not run into this issue at all - I had thought before that it did, but I was mistakenly using a different gamedata folder . . .

Therefore, I have to conclude that this stack trace error is indeed an "out-of-memory" related error . . . for whatever reason. I still don't see why it's more of a problem in the northern maps, but the few other mod threads I've seen this error reported, other players have run into it in areas like Cordon, Agro, etc.

Common denominator - those mods are also running AAO 1.8 + SWO3 + numerous other addons.

Considering sounds are at the bottom of the engine's cache/priority list, I can see where it's kicking this problem.

I'm curious now as to whether this is only an issue with x64 OSes or x86 OSes. I'm running x64 here, so . . .

nandersen - do you want me to go ahead and upload the whole of SWO3 + addons + AAO (which is the smallest I can cough up that duplicates the problem), or do you want to install those yourself and I just post up a couple of saves? The way it's looking right now, there might not exaclty be a "fix" for this problem (based on my deductions).

On a side not - do you want me to start using your current username, or does it matter?
  20:37:22  13 September 2010
profilee-mailreply Message URLTo the Top
notanumber
mod abuser & exploiter
(Resident)

 

 
On forum: 03/22/2008
Messages: 2822

---QUOTATION---
nandersen - do you want me to go ahead and upload the whole of SWO3 + addons + AAO (which is the smallest I can cough up that duplicates the problem), or do you want to install those yourself and I just post up a couple of saves? The way it's looking right now, there might not exaclty be a "fix" for this problem (based on my deductions).
---END QUOTATION---


Sorry, I think I'll pass. It seems that you've tracked it down. I doubt that the issue will be readily reproducible on a different system than yours.
Anyway, good job

---QUOTATION---
On a side not - do you want me to start using your current username, or does it matter?
---END QUOTATION---


You can call me anything you like as long as it's something nice
 
Each word should be at least 3 characters long.
Search:    
Search conditions:    - spaces as AND    - spaces as OR   
 
Forum Index » S.T.A.L.K.E.R.: Shadow of Chernobyl Forum » Mod discussion
 

All short dates are in Month-Day-Year format.


 

Copyright © 1995-2021 GSC Game World. All rights reserved.
This site is best viewed in Internet Explorer 4.xx and up and Javascript enabled. Webmaster.
Opera Software products are not supported.
If any problem concerning the site functioning under Opera Software appears apply
to Opera Software technical support service.