ProjectsWhat's NewDownloadsCommunitySupportCompany
Forum Index » S.T.A.L.K.E.R.: Shadow of Chernobyl Forum » Mod discussion
Odd CTD

1 2 3 4 | Next 10 events »| All Messages
Posted by/on
Question/AnswerMake Newest Up Sort by Descending
  03:08:57  6 September 2010
profilee-mailreply Message URLTo the Top
{imperialreign}
Звуковой Шаман
(Resident)

 

 
On forum: 10/29/2008
Messages: 3075
Odd CTD

Yerp, got another one I can't seem to circumvent, and can't pinpoint what's cuasing it, either.


stack trace:

0023:0040D025 XR_3DA.exe, CEnvAmbient::get_rnd_sound_time()
0023:7566206C iertutil.dll
0023:03D21D30 xrGame.dll



As of now, it only occurs in Stancia 1 and Sarcophagus . . . I can't get anymore than 5 minutes into the sarco before hitting this wall - I'm starting to believe this is some sort of timed-out error . . .

Running a minimal setup - SWO3+AAOv1.8

My first thought was that it was related to AAO . . . even though I never encountered this error during playtesting (nor playtesting compatibility with SWO3 or DW) . . . but, double checking all AAO configs and everything is fine. As well, if there was an issue within any of the weather sections, it would casue a CTD upon initial game startup - not at some random point in time after loading a saved game.

I had then thought it was related to the monolith call within the sarcophagus, and had attempted to adjust the timer there, and double check the sound_theme.script - all's well. It wasn't until I started fiddling around in Stancia1 that I noticed this problem there as well, so it couldn't be related to a config script and ph executions.

My only other thought was that it was possibly something corrupt within the saved game itself - so I went back to an earlier save (furthest being 10 in-game days prior to noticing this CTD) . . . then made a rush through AW, RF, Pri . . . only to discover the error is still there, leading me to believe it's probably not an issue with the save. I haven't yet tried a new game and speed through to these areas (which is next on my agenda) . . .

Any thoughts, guys? Only other conclusion I have would be excessive use/abuse of the weather speed-up function (provided via SWO3/DW). This isn't anything critical or requiring immediate attention, as I'm mearly doing some playtesting and taking sound samples. I'm just wanting to make 100% sure it's not an AAO issue - and if it is, get to the root of it so I can get a patch out.
  09:54:05  6 September 2010
profilee-mailreply Message URLTo the Top
Vintar
a bit of this and a lot of that
(Resident)

 

 
On forum: 08/08/2008
Messages: 6349
Is it possible to revert back to vanilla ambient sounds and retest?
  15:08:14  6 September 2010
profilee-mailreply Message URLTo the Top
notanumber
mod abuser & exploiter
(Resident)

 

 
On forum: 03/22/2008
Messages: 2822

---QUOTATION---
Odd CTD
stack trace:

0023:0040D025 XR_3DA.exe, CEnvAmbient::get_rnd_sound_time()
0023:7566206C iertutil.dll
0023:03D21D30 xrGame.dll


---END QUOTATION---


Dunno but I'd suspect something in env_ambient.ltx being outside of the range that the game can handle...
Is the problem reproducible?
  15:55:51  6 September 2010
profilee-mailreply Message URLTo the Top
{imperialreign}
Звуковой Шаман
(Resident)

 

 
On forum: 10/29/2008
 

Message edited by:
{imperialreign}
09/06/2010 15:59:26
Messages: 3075

---QUOTATION---
Is it possible to revert back to vanilla ambient sounds and retest?
---END QUOTATION---



I'll give it a shot, although I don't believe it'll make too much of a difference in the sounds themselves . . . although the configs might



---QUOTATION---
Dunno but I'd suspect something in env_ambient.ltx being outside of the range that the game can handle...
Is the problem reproducible?
---END QUOTATION---



That was one of my first thoughts, too - but double checking everything seems fine . . . unless the engine loaded them wrong at some point . . .

As to being reproducible - yes and no. I mean, it'll happen at some random interval in Stancia1 and Sarcophagus. I haven't had it happen in any other map, yet . . . and, I can't pin it down to any one specific sequence or sound or otherwise. It just happens whenever - especially in Stancia1 . . . I've gone anywhere from 5 minutes to 20 minutes there before it happens. In the sarcophagus, though, it happens within 5 minutes, but it's not consistent.


Either way - I'm assuming by it being a stack trace error that the problem is more than likely going to reside in some kind of error introduced by a script - that is, I get the impression that some kind of infinite loop is being introduced which is what's causing the overflow/out-of-memory issue. But, this could just be me talking out my ass, too. The game doesn't bog down at all (like it typically would by such a loop) before CTD.
  16:16:34  6 September 2010
profilee-mailreply Message URLTo the Top
notanumber
mod abuser & exploiter
(Resident)

 

 
On forum: 03/22/2008
Messages: 2822
Have you looked at the two weather phases that might be interesting? I assume that it's indoor weather but is the ambient the same for all phases of the cycle or is there a crossover between two different ambient configs at some point?
  00:28:29  7 September 2010
profilee-mailreply Message URLTo the Top
{imperialreign}
Звуковой Шаман
(Resident)

 

 
On forum: 10/29/2008
Messages: 3075

---QUOTATION---
Have you looked at the two weather phases that might be interesting? I assume that it's indoor weather but is the ambient the same for all phases of the cycle or is there a crossover between two different ambient configs at some point?
---END QUOTATION---



Regarding the indoor cycle - it's the same no matter what the hour . . . but, the sarcophagus has a different ambient setup than agro ungrnd, x18, x16, x19 or monolith.

As well, the ambient is entirelly different than Stancia1 - where it follows a theme specific to stancia1 (which is different than Pripyat's, Red Forest's, Cordon, etc.) throughout any weather cycle.
  06:35:28  7 September 2010
profilee-mailreply Message URLTo the Top
{imperialreign}
Звуковой Шаман
(Resident)

 

 
On forum: 10/29/2008
Messages: 3075
Sorry for the double post . . .

nandersen - I think I might be on to what has introduced the issue . . .

I scrapped the gamedata folder entirelly, and went back to a full vanilla loadout. No problems at all - the CTD has completely gone away.

So . . . I created a new gamedata folder and installed what I assumed was the most likely culprit: AAO. Only with vanilla compatibility . . . oddly enough, the problem doesn't exist at all . . .

But, if I patch AAO to SWO3 or DW, it resumes . . . the least common denominator here would have to revolve around the DW engine - either the script itself, or possibly an error introduced with the ambient_env extensions and/or the script handling them (which is, IMHO, where the problem probably lies, more-so than within the actual l_w.script).

As of now, still, the only maps that appear to have this problem seem to be Stancia1 and Sarcophagus . . .

Any ideas? I'm wondering if the game engine might be trying to cache too many sounds during a transition . . . but, at the same time, the ambient_env configs for stancia1 and sarcof are actually fairly light - especially when compared against those of Pripyat or Red Forest, or X18 or agro_ugrnd . . .
  08:43:11  7 September 2010
profilee-mailreply Message URLTo the Top
Vintar
a bit of this and a lot of that
(Resident)

 

 
On forum: 08/08/2008
Messages: 6349
You mentioned something about the weather cycles being sped up?

Could this be the cause?
  14:20:47  7 September 2010
profilee-mailreply Message URLTo the Top
{imperialreign}
Звуковой Шаман
(Resident)

 

 
On forum: 10/29/2008
Messages: 3075

---QUOTATION---
You mentioned something about the weather cycles being sped up?

Could this be the cause?
---END QUOTATION---



At this point, doubtful.

I just did a speed-run through from a new game start to NPP, and ran into the problem - it was still May 1st 2012 in-game.
  17:55:01  7 September 2010
profilee-mailreply Message URLTo the Top
notanumber
mod abuser & exploiter
(Resident)

 

 
On forum: 03/22/2008
Messages: 2822
If I remember correctly the weather script still runs random weather cycle selection in the background but applies the indoor cycle. Have you noticed if the crash happens around one of the times configured for weather transitions? Maybe the weather doesn't like to be set to what it already is (at least with the ambient changes).
Does it still crash if you use a different env_ambient value for the sarcofag?
 
Each word should be at least 3 characters long.
Search:    
Search conditions:    - spaces as AND    - spaces as OR   
 
Forum Index » S.T.A.L.K.E.R.: Shadow of Chernobyl Forum » Mod discussion
 

All short dates are in Month-Day-Year format.


 

Copyright © 1995-2021 GSC Game World. All rights reserved.
This site is best viewed in Internet Explorer 4.xx and up and Javascript enabled. Webmaster.
Opera Software products are not supported.
If any problem concerning the site functioning under Opera Software appears apply
to Opera Software technical support service.