ProjectsWhat's NewDownloadsCommunitySupportCompany
Forum Index » S.T.A.L.K.E.R.: Shadow of Chernobyl Forum » Mod downloads
O.G.S.E. 0.6.9.3 OGSR x64 1.0007 Engine Update

Posted by/on
Question/AnswerMake Newest Up Sort by Descending
  11:24:34  29 June 2019
profilee-mailreply Message URLTo the Top
gibe86
(Senior)
 
On forum: 01/26/2011
 

Message edited by:
gibe86
06/29/2019 12:52:40
Messages: 69
O.G.S.E. 0.6.9.3 OGSR x64 1.0007 Engine Update

Hey !!!
New update 'x64 xray engine' on mobdb => https://www.moddb.com/downloads/ogse-0693-ogsr-x64-10007-engine-update

This update brings improved OGSR x64 1.0007 Engine to OGSE. OGSR it's the result of X-Ray engine improvements by modding enthusiasts, it's a very stable x64-only engine without 4Gb memory limit, greatly improved performance and stability, improved rendering.
OGSR Engine for OGSE 0.6.9.3 (23-06-2019)


Hello everyone, this is KamikaZze. I've been out of touch for some time, but while I was, guys who continued development, done a huge accomplishment.
They've been able to recompile X-Ray engine to x64 architecture and fix a lot of it's flaws in the process. Result is a very stable engine without 4Gb memory limit, greatly improved performance and stability, improved rendering.

Good news about it is what due to the fact what development was initially based on OGSE, new engine has been born initially compatible with it. And it's maintainer, KRodinn, made it available on the GitHub.

Here is the page of OGSR Engine on GitHub: OGSR-Engine
And here is the page of updated resources for OGSE port on OGSR Engine: OGSR-Resources

Using this resources, I've created this update, to simplify the process of installation of OGSR engine to OGSE. My work here is only the installer itself.

Prerequisites:


1) Windows 7/8/8.1/10 x64 with 4 Gb of RAM or more.
2) GPU capable of dynamic rendering.
3) Installed OGSE 0.6.9.3, updated to version 2.10R.

Installation Instructions:


Before installing, make sure that you have installed update 0.6.9.3 to version 2.10R.
After that, before installing this package, at least once run the OGSE configurator to create all the necessary folders.

Possible issues:


1) On 21:9 resolutions left shoulder could appear on side of the screen for some weapons.
To fix that, open the console and set "hud_fov" parameter to 0.31

2) If on launch it couldn't find OpenAL libs, please install latest ones from Openal.org

3) If you have localization issues, first run the OGSE_Configurator after installing this package and set the language to English. Second, apply this small fix for news feed and treasure manager (thanks to Anna_Maniac for that): Mega.nz
 
Each word should be at least 3 characters long.
Search:    
Search conditions:    - spaces as AND    - spaces as OR   
 
Forum Index » S.T.A.L.K.E.R.: Shadow of Chernobyl Forum » Mod downloads
 

All short dates are in Month-Day-Year format.


 

Copyright © 1995-2019 GSC Game World. All rights reserved.
This site is best viewed in Internet Explorer 4.xx and up and Javascript enabled. Webmaster.
Opera Software products are not supported.
If any problem concerning the site functioning under Opera Software appears apply
to Opera Software technical support service.