ProjectsWhat's NewDownloadsCommunitySupportCompany
Forum Index » S.T.A.L.K.E.R.: Shadow of Chernobyl Forum » Mod discussion
ZRP - A joint effort in fixing S.T.A.L.K.E.R.

« Previous 10 events | 1 ... 345 346 347 348 349 350 351 352 353 ... 368 | Next 10 events »
Question Do YOU want an unofficial patch?
Answers
Yes, I'm desperate!
Yeh, why not...
I don't care either way.
Could easily do without it...
Decane, stop spamming the forums with your dumb ideas! NO!
Posted by/on
Question/AnswerMake Oldest Up Sort by Ascending
  06:16:56  16 November 2007
profilee-mailreply Message URLTo the Top
NatVac
Senior Resident
 

 
On forum: 06/15/2007
Messages: 4261
russao, since your mods are not using the ZRP, I can only make guesses about the cause.

Guess 1: Mixed modules from different versions.

I'd look for an extra p:w_*(*) or two in the save() function of one of your modules. The save file might be getting extra data and confusing the load() routines.

I have been on an unintentional road of discovery. Did you know that if you rename gamedata.dbc to gamedata.dbc.x, the engine still finds it and uses it? Even in version 1.0004?

So make sure you don't have gamedata.dbc in your STALKER installation directory if you are running 1.0004.

Guess 2: You are trying to load a 1.0005 saved game into 1.0004. This is similar to guess 1 in that the persistence is different than what is expected by the game.

Guess 3: This is not likely, but you can check the current_server_object_version value in system.ltx. Victim, <Snitch>this information might be of some use to you, stalker.</Snitch>

If I have it set to 7 when I save a game in 1.0004, that saved game will usually have a "can't open section" error under 1.0005. Maybe it is messing up the save/load stuff even in 1.0004.

fatrap, I'm using a slightly-modified version of Show Rewards 1.02 in the ZRP. It also notes whether or not you need to return for reward.

Folks, I believe I have a version that is compatible with 1.0004 and 1.0005, as long as the current_server_object_version value is consistent with the saved games. No, I'm not using that variable; I'm using the actual game version string, but 1.0004 games saved with that value set to 7 won't load in 1.0005.

I'll upload it after I update some of the documentation. There would also be an issue with the Carry Weight configuration item; the version should match the game version. I'll put the new stuff in a separate directory, so it will be easy to see what is different.
  21:33:14  15 November 2007
profilee-mailreply Message URLTo the Top
russao
(Senior)
 
On forum: 06/18/2007
Messages: 120
Im getting a weird error:

[error]Expression : fatal error
[error]Function : CInifile::r_section
[error]File : E:stalkerpatch_1_0004xrCoreXr_ini.cpp
[error]Line : 342
[error]Description : <no expression>
[error]Arguments : Can't open section 'acactor'

"Can't open section 'acactor'"

it seems like a typo mistake, "actor" instead of "acactor", but i have seen people also getting this "Can't open section 'ac'" instead of "ac actor"

the thing is there is no such section as "ac" or "acactor", i did a full search for both terms, also as "ac\actor" or "ac_actor", but i couldnt find anything, i also did a search in all.spawn, nothing is wrong.

but some how at some point the game save "acactor" as a section or whatever, the only place i could find it, was obvious, in my save game:

#ÜÿÝ..Ý..Ý..Ý..Ý..Ý..Ý..Ý..Ý..Ý..Ü........1<.`I..Z...acactor‘.†T...ð...Marked One.$ediz..ÿ .#”

there i can see "acactor" which is giving me that error, i wonder if anyone know what could be causing it since there is no type mistakes or sections named as "ac" or "acactor" or "ac\acactor".

i wonder if the game is passing corrupted data to save game file and if im not wrong this error is happening only in bar.
  20:12:40  15 November 2007
profilee-mailreply Message URLTo the Top
NatVac
Senior Resident
 

 
On forum: 06/15/2007
Messages: 4261
fatrap, it's the same problem as mentioned in my previous post: The callback is getting a string instead of a number, and trying to do math on a string doesn't work here. Converting it back to a number should work.

Since the Show Rewards mod is called in task_manager.script, and since the reputation bug needs to be fixed there anyway, maybe the fix at the source would be more practical than the Whack-A-Mole workaround on every place it is used. I'll post more after I finish debugging later, although real life has a nasty habit of intruding...
  16:20:10  15 November 2007
profilee-mailreply Message URLTo the Top
fatrap
The Wrinkled One
(Resident)

 

 
On forum: 08/01/2007
 

Message edited by:
fatrap
11/15/2007 16:23:05
Messages: 2279
NatVac, I don't see what the problem is with this "show reward" script. Can you take a peek at it and point me in the right direction? Also... I don't remember whether the ZRP included this function as an option. If not, it might be something worth considering as it really adds to the gameplay experience.

EDIT: I will email this to you 'cause I am just not up to dealing with the forum software in posting it here.... smiley paradise!
  13:56:09  15 November 2007
profilee-mailreply Message URLTo the Top
fatrap
The Wrinkled One
(Resident)

 

 
On forum: 08/01/2007
 

Message edited by:
fatrap
11/15/2007 14:21:49
Messages: 2279
Hey NatVac..... I converted the mod I am working on to 1.0005 specs and got it to fire up. I do have a "show reward" function built into it and it did not work. There also is a "repair weapons / armor" function in it but I did not have a chance to look at that. I am assuming that the show_reward.script file will have to be re-written or modified because this is the line in the task_manager script file that fires it up and I don't see anything wrong with it:

show_reward.add_reward_display(phr)

This "show reward" function is a nice little addition to any mod. So is the "repair" functions. I will go check on the repair function and see if it is working. (Was too pooped last night to do it)

I did notice that the screens Victim made appeared to be working fine and it appeared that all my custom items and settings were OK. My initial guess is that everything will work as long as they have no dialog connections.


EDIT: Update... the Repair Mod portion of my mod works fine with 1.0005. Interesting side note.... there are usually 5 "cut-out zombies" at the particular place I went to... under the new patch there were only 2. I am putting these zombies in with a se_respawn.script.... guess I better have a peek at it too!
  10:46:22  15 November 2007
profilee-mailreply Message URLTo the Top
NatVac
Senior Resident
 

 
On forum: 06/15/2007
Messages: 4261
Yes, Nightwatch, ZRP 1.04 is not compatible with 1.0005 as is. The task_manager.script and xr_motivator.script files need to be changed in the ZRP, and other mods based on it might need the dialog_manager.script file changed as well.

The good news is that the dialogs and text do not need to be rewritten, fatrap and Victim.

Well, there's a bit more than just the simple conversion, but I pretty much have a 1.0004 task_manager.script running under 1.0005.

You can marshal the data so that the 1.0004 engine is happy, and the 1.0005 engine is happy. But the callbacks also need to be managed, because the newer engine returns strings instead of numbers.

The same solution should work for the dialog_manager.script as well.

I still have to fix one crash in first trying to talk with Lukash (from an autosave, but not from a save after that). I also have a possible gotcha to solve: the versioning is currently based on the API call script_server_object_version(). But modders like to supply custom versions of system.ltx, which has that value (see "[script]") set to 7 in version 1.0005 and 6 in version 1.0004. That means I can't trust it. Anyone know a specific engine version reference?

If you are going to supply different versions of system.ltx for compatibility, then it would be easier to supply different versions of the changed script files as well...

Once I get these resolved, I'll update the ZRP archive (compatibility update only), but it will likely be another day or so.

Let me say that I am not happy about 1.0005 either, fatrap, and for more reasons than just the extra work it makes for modders. My primary complaint is that I'm experiencing very frequent irregular hitches playing the game on my PC (no, it's not the ZRP stuff), and I didn't have that problem with 1.0004.

Can anyone tell me what value the new patch brings to single-player besides the Bes dialog fix? The change notes say very little.

I agree with yellow helicopter: It would have taken them two minutes to fix the task manager reputation bug while they were changing the file anyway.

I'm glad to hear the screens work, Victim. There's a bright spot.
  04:14:59  15 November 2007
profilee-mailreply Message URLTo the Top
Victim
Senior Resident
 

 
On forum: 05/21/2005
 

Message edited by:
Victim
11/15/2007 4:26:18
Messages: 1089

---QUOTATION---
But you say that 6 works?
---END QUOTATION---



It's right there for you to try. I installed v1.0005 on top of v1.0004, installed that mod and it worked fine. I'll change the 6 to a 7 in system.ltx and see what happens.

Were you expecting that it'd crash if "6" was used?

@ Fatrap: You and me both bro.

EDIT/ 7 also works.

EDIT2/ Just adding that the UI mod I'm working on for your ZRP also works fine under v1.0005.
  01:17:44  15 November 2007
profilee-mailreply Message URLTo the Top
fatrap
The Wrinkled One
(Resident)

 

 
On forum: 08/01/2007
Messages: 2279
Nightwatch, this is not very good news! Sounds like a lot of dialogs are going to have to be re-written for existing mods to work with 1.0005...... I sure hope that I am wrong!
  20:01:40  14 November 2007
profilee-mailreply Message URLTo the Top
Nightwatch
Senior Resident
 

 
On forum: 08/13/2007
Messages: 952
ZRP does not work with 1.0005

After I installed the 1.0005 patch and tried on clean vanilla Stalker from the start (a new game), I found the patch is very disappointing with increased (yes, increased) stutter alongside some other problems which need to be the subject of another section. Therefore, as I had tried and got impressed by its results, I wanted to install ZRP hoping that ZRP could help. But the the game started CTD at any attemp of loading a save game made on vanilla Stalker patched 1.0005. It barely reached to "Synchronizing" part of loading process.

Then, I gave up trying to load a saved game (1.0005 patched) now ZRP modded game and decided to start a new game.
The game started alright, but when I said -rather clicked- on sedorovic dialog in order to accept the first mission, the game crashed (CTD) just after I heard that the door was unlocked.
Several tries, the same result. This patch is disappointing. It did not bring any major improvements and made at least some of the mods unuseable.
I use Vista ultimate 32 bit.

there is a very small error line on the x-ray log:

[error][ 259] : No more data is available.

So, after I've written this post, I will uninstall the game and reinstall it with 1.0004 patch -what an unnecessary trouble.
Then, I'll put ZRP and try to forget it has ever happened.
  14:21:32  14 November 2007
profilee-mailreply Message URLTo the Top
Don Reba
Bishop and Councilor of War
(Moderator)

 

 
On forum: 12/04/2002
Messages: 11601
Thanks. Copied your posts into a new thread.
 
Each word should be at least 3 characters long.
Search:    
Search conditions:    - spaces as AND    - spaces as OR   
 
Forum Index » S.T.A.L.K.E.R.: Shadow of Chernobyl Forum » Mod discussion
 

All short dates are in Month-Day-Year format.


 

Copyright © 1995-2019 GSC Game World. All rights reserved.
This site is best viewed in Internet Explorer 4.xx and up and Javascript enabled. Webmaster.
Opera Software products are not supported.
If any problem concerning the site functioning under Opera Software appears apply
to Opera Software technical support service.